phpmyadmin 配置文件权限错误,不应任何用户都能修改!

用路由器搭建本地网站时遇到"phpmyadmin 配置文件权限错误,不应任何用户都能修改!"问题,百度后得到答案。

 

如果部署的phpmyadmin权限为所有人可写,即权限为777,就会报"Wrong permissions on configuration file, should not be world writable!" 这个错误。

可以通过修改文件夹权限解决:
#chmod -R 755 phpmyadmin
(ubuntu)
$sudo chmod -R 755 phpmyadin

以上适用于电脑终端。

路由器可以直接通过WinSCP登陆路由器文件系统更改权限。

也可以通过修改phpmyadmin的配置文件解决:
找到phpmyadmin/libraries/config.default.php文件,
把 $cfg['CheckConfigurationPermissions'] 修改为false。

发表评论

您的电子邮箱地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据